Support Desk Upgrade Thursday 28th September 2017 15:30:00


Fixed - This has been completed. The support site is now back online.
Sep 28, 15:44 CDT

In Progress - We're presently updating the JIRA Service Desk software which powers our support site. We expect this to take no longer than 45 minutes.
Sep 28, 15:30 CDT