Website Non-Responsive Friday 2nd February 2018 14:35:00


Fixed - After continued monitoring of the server we have not seen any further issues. We're marking this one as resolved for now.
Feb 2, 15:45 CST

Watching - After further investigation, it appears there's were a number of IPs sending what appears to be malicious traffic to the server. These IPs have been blocked and the site should be responsive now. We'll continue to monitor the server for further issues.
Feb 2, 14:54 CST

Investigating - We're presently investigating an issue with the website not responding. We'll provide further updates shortly.
Feb 2, 14:35 CST